Search
20 January 2019 ..:: Help » KitchenAid Help » Food Processor Problem Solving ::.. Register   Login
 Shopping Basket Minimize
Basket is empty

    
 Text/HTML Minimize

 

We hope the following information will help if you are experiencing problems with your KitchenAid Food Processor.  If your problem does not have a solution below please do not hesitate to contact us.  To make it easier for us to help you please email us with model number, pictures or video and a description of the problem.

 

If your food processor feed tube is stuck in the pusher please follow the next few steps.

It is possible that  the Feed Tube Pusher can become wedged in the Feed Tube.

This can be caused by food caught between the sections.

Follow the next step to help resove the issue.

Soak the Work Bowl cover in warm water, or wash in a Dishwasher to warm the pusher, this should make it easier to remove.

 

Blade stuck on shaft.

Using your food processor for a long period of time can produce heat. When enough heat is produced it can cause the blades  to fuse with motor shaft.

The next steps may help you remove the blade form the motor shaft.

 

Remove the Work Bowl lid and unlock the Work Bowl from the base so that it spins freely.​​

Gently pull up on the Work Bowl while rotating it around he motor shaft.

This should put enough pressure on the bottom of the blade, to help dislodge it from the shaft.If you are able to remove the blade, inspect the motor shaft and the inside of the multipurpose blade for damage. If there is damage be careful not to use the blade or shaft again as the problem will be repeated.

 

Food Processor Shuts off whilst in use.

Food processors can overheat and will shut off.

Once the food processor has cooled down completely it should work again.

Newer food processors are fitted with a current limiting device, this will help protect against overheating. 

The limiting device will trip out if you are processing a heavy load.

If the food processor does not restart after it has cooled down for at least 30 minutes, then follow the next steps to reset the limiting device.

Remove the pusher assembly.

Release and relock the lid.

Release and relock the bowl 

Unplug from socket and plug back in.

This should resolve the issue.

 


  

 

 

Copyright 2009-2019 by K A Parts Limited, registered in the UK 7047084   Terms Of Use  Privacy Statement
DotNetNuke® is copyright 2002-2019 by DotNetNuke Corporation